using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+(?=_)";
string substitution = @"666";
string input = @"string/1_491107.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}