const regex = /[0-9]+(?=_)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+(?=_)', '')
const str = `string/1_491107.jpg`;
const subst = `666`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);