$re = '/[0-9]+(?=_)/';
$str = 'string/1_491107.jpg';
$subst = "666";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;