#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/({*([a-z0-9]+[a-zA-Z0-9{}]*)?}*\/?)+$"
Local $sString = "/acbAbf023/{acfAbc12}/asp/avbTfg/abd01" & @CRLF & _
"/NotCamel/case" & @CRLF & _
"/abc123/123/123abc/{nested{bracket}}/{{}}/{}/" & @CRLF & _
"/inv$l!d/" & @CRLF & _
"//doubleslash/{blockEnd}" & @CRLF & _
"/snake_case/" & @CRLF & _
"/UPPERCASE" & @CRLF & _
"{}" & @CRLF & _
"//" & @CRLF & _
"///multiple" & @CRLF & _
"/{}" & @CRLF & _
"{}/" & @CRLF & _
"/}////{}///"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")