import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(\\{*([a-z0-9]+[a-zA-Z0-9\\{\\}]*)?\\}*\\/?)+$";
final String string = "/acbAbf023/{acfAbc12}/asp/avbTfg/abd01\n"
+ "/NotCamel/case\n"
+ "/abc123/123/123abc/{nested{bracket}}/{{}}/{}/\n"
+ "/inv$l!d/\n"
+ "//doubleslash/{blockEnd}\n"
+ "/snake_case/\n"
+ "/UPPERCASE\n"
+ "{}\n"
+ "//\n"
+ "///multiple\n"
+ "/{}\n"
+ "{}/\n"
+ "/}////{}///";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}