// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/({*([a-z0-9]+[a-zA-Z0-9{}]*)?}*\/?)+$").unwrap();
let string = "/acbAbf023/{acfAbc12}/asp/avbTfg/abd01
/NotCamel/case
/abc123/123/123abc/{nested{bracket}}/{{}}/{}/
/inv$l!d/
//doubleslash/{blockEnd}
/snake_case/
/UPPERCASE
{}
//
///multiple
/{}
{}/
/}////{}///";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}