package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/({*([a-z0-9]+[a-zA-Z0-9{}]*)?}*\/?)+$`)
var str = `/acbAbf023/{acfAbc12}/asp/avbTfg/abd01
/NotCamel/case
/abc123/123/123abc/{nested{bracket}}/{{}}/{}/
/inv$l!d/
//doubleslash/{blockEnd}
/snake_case/
/UPPERCASE
{}
//
///multiple
/{}
{}/
/}////{}///`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}