re = /^\/({*([a-z0-9]+[a-zA-Z0-9{}]*)?}*\/?)+$/m
str = '/acbAbf023/{acfAbc12}/asp/avbTfg/abd01
/NotCamel/case
/abc123/123/123abc/{nested{bracket}}/{{}}/{}/
/inv$l!d/
//doubleslash/{blockEnd}
/snake_case/
/UPPERCASE
{}
//
///multiple
/{}
{}/
/}////{}///'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end