const regex = /πc=(?<MyFileName>[^&]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('πc=(?<MyFileName>[^&]*)', 'g')
const str = `...........πc=pic%231.pdf&description=.......
...........πc=pic.pdf&description=.......
...........πc=pic%232.pdf&description=.......
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}