re = /πc=(?<MyFileName>[^&]*)/
str = '...........πc=pic%231.pdf&description=.......
...........πc=pic.pdf&description=.......
...........πc=pic%232.pdf&description=.......
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end