$re = '/πc=(?<MyFileName>[^&]*)/';
$str = '...........πc=pic%231.pdf&description=.......
...........πc=pic.pdf&description=.......
...........πc=pic%232.pdf&description=.......
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);