using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span><h2>(.*?)<\/h2><\/span>";
string input = @"фывфывфы
<span><h2>Заголовок</h2></span>фафыафыа
<span><h2>Заголовок</h2></span>
пывпы ыв ыва ывавы
<span><h3>Заголовок</h3></span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}