$re = '/<span><h2>(.*?)<\/h2><\/span>/m';
$str = 'фывфывфы
<span><h2>Заголовок</h2></span>фафыафыа
<span><h2>Заголовок</h2></span>
пывпы ыв ыва ывавы
<span><h3>Заголовок</h3></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);