const regex = /<span><h2>(.*?)<\/h2><\/span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span><h2>(.*?)<\\\/h2><\\\/span>', 'gm')
const str = `фывфывфы
<span><h2>Заголовок</h2></span>фафыафыа
<span><h2>Заголовок</h2></span>
пывпы ыв ыва ывавы
<span><h3>Заголовок</h3></span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}