package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span><h2>(.*?)<\/h2><\/span>`)
var str = `фывфывфы
<span><h2>Заголовок</h2></span>фафыафы а
<span><h2>Заголовок</h2></span>
пывпы ыв ыва ывавы
<span><h3>Заголовок</h3></span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}