// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<span><h2>(.*?)<\/h2><\/span>").unwrap();
let string = "фывфывфы
<span><h2>Заголовок</h2></span>фафыафыа
<span><h2>Заголовок</h2></span>
пывпы ыв ыва ывавы
<span><h3>Заголовок</h3></span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}