# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/, *(?=[^(]*\))//gm;t' <<< "BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)
BlockedMatch(XA,YB), Correlation(XA,QC), Correlation(YB,QC), Correlation(QC,YB)
BlockedMatch(XA, YB, ZB), Correlation(XA, QC, FR), Correlation(YB, QC, BX), Correlation(QC, YB, ZZ)
BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)
"