const regex = /, *(?=[^(]*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', *(?=[^(]*\\))', 'gm')
const str = `BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)
BlockedMatch(XA,YB), Correlation(XA,QC), Correlation(YB,QC), Correlation(QC,YB)
BlockedMatch(XA, YB, ZB), Correlation(XA, QC, FR), Correlation(YB, QC, BX), Correlation(QC, YB, ZZ)
BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);