#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m), *(?=[^(]*\))"
Local $sString = "BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)" & @CRLF & _
"BlockedMatch(XA,YB), Correlation(XA,QC), Correlation(YB,QC), Correlation(QC,YB)" & @CRLF & _
"BlockedMatch(XA, YB, ZB), Correlation(XA, QC, FR), Correlation(YB, QC, BX), Correlation(QC, YB, ZZ)" & @CRLF & _
"" & @CRLF & _
"BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)