$re = '/, *(?=[^(]*\))/m';
$str = 'BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)
BlockedMatch(XA,YB), Correlation(XA,QC), Correlation(YB,QC), Correlation(QC,YB)
BlockedMatch(XA, YB, ZB), Correlation(XA, QC, FR), Correlation(YB, QC, BX), Correlation(QC, YB, ZZ)
BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;