# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(x(\d)(,)?)(x(\d)(,)?)?/X$2,X$5$3O$2,O$5$3/g;t' <<< "X1,O1,X2,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups broken apart
x1,x2,Z3,x4,Z5,x6
X1,X2,O1,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups kept together"