import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(x(\\d)(,)?)(x(\\d)(,)?)?";
final String string = "X1,O1,X2,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups broken apart\n"
+ "x1,x2,Z3,x4,Z5,x6\n"
+ "X1,X2,O1,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups kept together";
final String subst = "X$2,X$5$3O$2,O$5$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}