import re
regex = re.compile(r"(x(\d)(,)?)(x(\d)(,)?)?")
test_str = ("X1,O1,X2,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups broken apart\n"
"x1,x2,Z3,x4,Z5,x6\n"
"X1,X2,O1,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups kept together")
subst = "X$2,X$5$3O$2,O$5$3"
result = regex.sub(subst, test_str)
if result:
print(result)