using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(x(\d)(,)?)(x(\d)(,)?)?";
string substitution = @"X$2,X$5$3O$2,O$5$3";
string input = @"X1,O1,X2,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups broken apart
x1,x2,Z3,x4,Z5,x6
X1,X2,O1,O2,Z3,X4,O4,Z5,X6,O6 <- repeated groups kept together";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}