# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[b\](.*?)\[\\/b\]//gm;t' <<< "[b]foo[/b]foo[b]bar[/b]"