using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[b\](.*?)\[\/b\]";
string substitution = @"";
string input = @"[b]foo[/b]foo[b]bar[/b]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}