package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[b\](.*?)\[\/b\]`)
var str = `[b]foo[/b]foo[b]bar[/b]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}