$re = '/\[b\](.*?)\[\/b\]/m';
$str = '[b]foo[/b]foo[b]bar[/b]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;