using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?([-\w\d@:%._\+~#=]{1,256})?\.([\w\d()]{1,6})(\b[^.][-\w\d()@:%_\+.~#?&//=]*?)?(\.*(?:\b|\B))
";
string input = @"example.org..
www.example.org.....
example.org/some/end/string
example.org/?someendsctringSOow?2332q3=sda33ad.
www.example.org/some/end/string.
example1.example.org/?someendsctringSOow?2332q3=sda33ad
https://example34.domain.org/?someendsctringSOow?2332q3=sda33ad...
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}