import re
regex = re.compile((r"(https?:\/\/)?([-\w\d@:%._\+~#=]{1,256})?\.([\w\d()]{1,6})(\b[^.][-\w\d()@:%_\+.~#?&//=]*?)?(\.*(?:\b|\B))\n"), flags=re.MULTILINE)
test_str = ("example.org..\n"
"www.example.org.....\n"
"example.org/some/end/string\n"
"example.org/?someendsctringSOow?2332q3=sda33ad.\n"
"www.example.org/some/end/string.\n"
"example1.example.org/?someendsctringSOow?2332q3=sda33ad\n"
"https://example34.domain.org/?someendsctringSOow?2332q3=sda33ad...\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")