// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/)?([-\w\d@:%._\+~#=]{1,256})?\.([\w\d()]{1,6})(\b[^.][-\w\d()@:%_\+.~#?&//=]*?)?(\.*(?:\b|\B))
").unwrap();
let string = "example.org..
www.example.org.....
example.org/some/end/string
example.org/?someendsctringSOow?2332q3=sda33ad.
www.example.org/some/end/string.
example1.example.org/?someendsctringSOow?2332q3=sda33ad
https://example34.domain.org/?someendsctringSOow?2332q3=sda33ad...
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}