const regex = /(https?:\/\/)?([-\w\d@:%._\+~#=]{1,256})?\.([\w\d()]{1,6})(\b[^.][-\w\d()@:%_\+.~#?&//=]*?)?(\.*(?:\b|\B))
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?([-\\w\\d@:%._\\+~#=]{1,256})?\\.([\\w\\d()]{1,6})(\\b[^.][-\\w\\d()@:%_\\+.~#?&\/\/=]*?)?(\\.*(?:\\b|\\B))
', 'gm')
const str = `example.org..
www.example.org.....
example.org/some/end/string
example.org/?someendsctringSOow?2332q3=sda33ad.
www.example.org/some/end/string.
example1.example.org/?someendsctringSOow?2332q3=sda33ad
https://example34.domain.org/?someendsctringSOow?2332q3=sda33ad...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}