$re = '/(https?:\/\/)?([-\w\d@:%._\+~#=]{1,256})?\.([\w\d()]{1,6})(\b[^.][-\w\d()@:%_\+.~#?&//=]*?)?(\.*(?:\b|\B))
/m';
$str = 'example.org..
www.example.org.....
example.org/some/end/string
example.org/?someendsctringSOow?2332q3=sda33ad.
www.example.org/some/end/string.
example1.example.org/?someendsctringSOow?2332q3=sda33ad
https://example34.domain.org/?someendsctringSOow?2332q3=sda33ad...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);