using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*)([a-z]*)(\d*)([a-z]*)(\d*)([a-z]*)$";
string input = @"1234abc234qwy2342nioo
23oin234noik32342noi
234nio234koi2341nio";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}