package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\d*)([a-z]*)(\d*)([a-z]*)(\d*)([a-z]*)$`)
var str = `1234abc234qwy2342nioo
23oin234noik32342noi
234nio234koi2341nio`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}