// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(\d*)([a-z]*)(\d*)([a-z]*)(\d*)([a-z]*)$").unwrap();
let string = "1234abc234qwy2342nioo
23oin234noik32342noi
234nio234koi2341nio";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}