$re = '/^(\d*)([a-z]*)(\d*)([a-z]*)(\d*)([a-z]*)$/mi';
$str = '1234abc234qwy2342nioo
23oin234noik32342noi
234nio234koi2341nio';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);