re = /^(\d*)([a-z]*)(\d*)([a-z]*)(\d*)([a-z]*)$/mi
str = '1234abc234qwy2342nioo
23oin234noik32342noi
234nio234koi2341nio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end