using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0|[1-9][\d]*)\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\w+))(?(Special)\h+@([^\v]*|)@|\h*([^\v]*|))";
string input = @"0 @Reference@ Objekt
1 NAME Max /Mustermann/
2 DATE 22 APR 2016
1 FAMC @I123@
1 FAMS @I124@
1 CHIL @I125@";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}