import re
regex = re.compile(r"(0|[1-9][\d]*)\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\w+))(?(Special)\h+@([^\v]*|)@|\h*([^\v]*|))", flags=re.MULTILINE)
test_str = ("0 @Reference@ Objekt\n"
"1 NAME Max /Mustermann/\n"
"2 DATE 22 APR 2016\n"
"1 FAMC @I123@\n"
"1 FAMS @I124@\n"
"1 CHIL @I125@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")