const regex = /(0|[1-9][\d]*)\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\w+))(?(Special)\h+@([^\v]*|)@|\h*([^\v]*|))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0|[1-9][\\d]*)\\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\\w+))(?(Special)\\h+@([^\\v]*|)@|\\h*([^\\v]*|))', 'gm')
const str = `0 @Reference@ Objekt
1 NAME Max /Mustermann/
2 DATE 22 APR 2016
1 FAMC @I123@
1 FAMS @I124@
1 CHIL @I125@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}