$re = '/(0|[1-9][\d]*)\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\w+))(?(Special)\h+@([^\v]*|)@|\h*([^\v]*|))/m';
$str = '0 @Reference@ Objekt
1 NAME Max /Mustermann/
2 DATE 22 APR 2016
1 FAMC @I123@
1 FAMS @I124@
1 CHIL @I125@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);