import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(css|js)\\?ver=\\d+\\.\\d\\.*\\d*$";
final String string = "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6\n"
+ "/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8.1\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2\n"
+ "/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.5\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2\n"
+ "/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6\n"
+ "/wp-content/plugins/wordpress-seo/css/dist/adminbar-1180.min.css?ver=11.8\n"
+ "/wp-content/plugins/wordpress-seo/css/dist/admin-global-1180.min.css?ver=11.8\n"
+ "/wp-content/plugins/wordpress-seo/css/dist/wpseo-dismissible-1180.min.css?ver=11.8\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2\n"
+ "/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.1\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2\n"
+ "/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6\n"
+ "/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}