import Foundation
let pattern = #"\.(css|js)\?ver=\d+\.\d\.*\d*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8.1
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2
/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2
/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/plugins/wordpress-seo/css/dist/adminbar-1180.min.css?ver=11.8
/wp-content/plugins/wordpress-seo/css/dist/admin-global-1180.min.css?ver=11.8
/wp-content/plugins/wordpress-seo/css/dist/wpseo-dismissible-1180.min.css?ver=11.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2
/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.1
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)