using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[TYPECODE #1\](NCHG)\[MARF#\][^ ].*?\[EREF#\][^ ].*?\[IREF#\][^ ].*?\[RTRN#]\s.*?\[DR #1\][^ ]";
string input = @"[TYPECODE #1]NCHG[MARF#]006-0030705-000 [IBAN#] [NAME#] [EREF#]006-0030705-00020/07/2015 [IREF#]006-0030705-00020/07/2015 [PREF#] [SVCL#] [CSID#] [RTRN#] [OCMT#] [OTHR#] [ORDT#] [REMI#] [BIC#][DR #1]3.00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}