use strict;
my $str = '[TYPECODE #1]NCHG[MARF#]006-0030705-000 [IBAN#] [NAME#] [EREF#]006-0030705-00020/07/2015 [IREF#]006-0030705-00020/07/2015 [PREF#] [SVCL#] [CSID#] [RTRN#] [OCMT#] [OTHR#] [ORDT#] [REMI#] [BIC#][DR #1]3.00';
my $regex = qr/\[TYPECODE #1\](NCHG)\[MARF#\][^ ].*?\[EREF#\][^ ].*?\[IREF#\][^ ].*?\[RTRN#]\s.*?\[DR #1\][^ ]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}