package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[TYPECODE #1\](NCHG)\[MARF#\][^ ].*?\[EREF#\][^ ].*?\[IREF#\][^ ].*?\[RTRN#]\s.*?\[DR #1\][^ ]`)
var str = `[TYPECODE #1]NCHG[MARF#]006-0030705-000 [IBAN#] [NAME#] [EREF#]006-0030705-00020/07/2015 [IREF#]006-0030705-00020/07/2015 [PREF#] [SVCL#] [CSID#] [RTRN#] [OCMT#] [OTHR#] [ORDT#] [REMI#] [BIC#][DR #1]3.00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}