// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[TYPECODE #1\](NCHG)\[MARF#\][^ ].*?\[EREF#\][^ ].*?\[IREF#\][^ ].*?\[RTRN#]\s.*?\[DR #1\][^ ]").unwrap();
let string = "[TYPECODE #1]NCHG[MARF#]006-0030705-000 [IBAN#] [NAME#] [EREF#]006-0030705-00020/07/2015 [IREF#]006-0030705-00020/07/2015 [PREF#] [SVCL#] [CSID#] [RTRN#] [OCMT#] [OTHR#] [ORDT#] [REMI#] [BIC#][DR #1]3.00";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}