#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\w{4})\h+(?=\w{4})"
Local $sString = "check24 smavey dr klein" & @CRLF & _
"smava" & @CRLF & _
"check24, interhyp" & @CRLF & _
"verivox check24 dr. klein" & @CRLF & _
"dr. klein" & @CRLF & _
"NA" & @CRLF & _
"dr. weber" & @CRLF & _
"dr. klein," & @CRLF & _
"NA" & @CRLF & _
"check24" & @CRLF & _
"check24 verivox" & @CRLF & _
"" & @CRLF & _
"Name1, Name2 Name3" & @CRLF & _
"Dr. Name1 Name2 Name3" & @CRLF & _
"AAA AAAA AAAA AAAA"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)