use strict;
my $str = 'check24 smavey dr klein
smava
check24, interhyp
verivox check24 dr. klein
dr. klein
NA
dr. weber
dr. klein,
NA
check24
check24 verivox
Name1, Name2 Name3
Dr. Name1 Name2 Name3
AAA AAAA AAAA AAAA';
my $regex = qr/(?<=\w{4})\h+(?=\w{4})/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";